Click On Tyler Support

Contact Us

Support Home » Hobo » Troubleshooting

Cannot Update WordPress Plugins and Themes

Last Updated April 21, 2015

If your copy of WordPress complains about needing FTP credentials to update themes and plugins while running inside a Vagrant box on Mac, you can modify Apache to run as the vagrant user.

Within your Vagrant box, edit this file


Search for the user and group directives. You can start scrolling down until you get there, the values should be ${APACHE_RUN_USER} and ${APACHE_RUN_GROUP}, respectively. Replace these two lines with the following:

User vagrant
Group vagrant

Then, restart Apache.